NeTAMS Debian package попытка вторая

Всё-таки допилил пакет NeTAMS до вменяемого состояния.
NeTAMS из CVS. (По политическим причинам.)

Брать в моем репозитории или напрямую из пула.

Пакеты собраны для Debian Lenny и Ubuntu Intrepid.

Обновление со старых версий пакета не поддерживается (в дальнейшем будет).

18 Replies to “NeTAMS Debian package попытка вторая”

  1. ну по пользованию в старом пакете только логи не ротились.
    а есть ссылка что поменялось в новой версии?

    1. В самом NeTAMS’е поменялось очень много чего. Появился биллинг, например более-менее вменяемый.
      Правда зато вебинтерфейс в каком-то странном состоянии: не то чтобы совсем не работает, но какой-то полуживой.
      Есть маленькая надежда, что авторы сделают новый интерфейс, по крайней мере они немножко за него взялись, но никаких гарантий нет.

      В пакете поменялось тоже много: он теперь при инсталляции сам создает базу MySQL, спрашивает про пароль администратора, нормально ротейтит логи, правильно раскрадывает файлы (в частности netams.conf теперь хранится в /var/lib/netams, так как это не конфиг, а хранилище). Ставит файлам правильные пермишены. Еще чего-то делает. Некоторое количество ошибок в самом нетамсе при пакетировании было поправлено.

      1. А, да, еще вебинтерфейс теперь нормально конфигурируется через конфиги в /etc/netams-web

      2. Правда зато вебинтерфейс в каком-то странном состоянии: не то чтобы совсем не работает, но какой-то полуживой.

        а статистику потребления трафика хоть показывает? я нетамс только ради учета трафика ставлю.

        1. Ну статистика выводится в static html, она работает нормально. Речь идет о вебинтерфейсе, который позволяет управлять пользователями/юнитами/политиками.
          Я правда не знаю, может он все же вполне рабочий – я просто им не пользуюсь. Но при пакетировании проверял – он, во-первых, много ворнингов выдает, во-вторых, какой-то из диалогов глючил.

          1. а ну да – уж подзабыл 🙂 я тоже админкой не пользуюсь, телнета и netamsctl за глаза хватает…

  2. При установке выдаёт запрос на пароль – ввожу (с подтверждением).
    Потом выдаёт через whiptail сначала что пароль не совпадает (вводил в обоих случаях “7890”), а потом блокирует работу вообще выводом

    Configuring netams
    Password input error!
    Please enter non-empty password.

    Кнопка “Ок” не реагирует на нажатие. Сносится только снятием процессов установки. Последующие попытки dpkg-reconfigure приводят к той же фигне.

    Что-то неправильно делаю?
    Как-то это лечится?

    ЗЫЖ Система Debian Lenny.

    1. Это баг.
      Вероятно, я его уже поправил, потому что на него (или почти на него) наталкивался уже. Когда обновленный пакет выложу – не очень представляю. Попробую на днях это сделать. Лучше всего, если напишешь мне мылом на gq@cs.msu.su – я тогда сразу, как будет готов пакет, тебе напишу.

  3. проблема
    Configuring netams
    Password input error!
    осталась. Есть какие-нибудь предложения ?
    Система Ubuntu-server 8.10

    1. Дождаться, когда я соберу новую версию в пакет. 🙁 к сожалению, со сроками достаточно туманно – времени сейчас совсем нет.

  4. Сейчас появилась еще проблема с вэб интерфейсом.
    Права раздаются на чтение только руту и после каждой конфигурации переписываются. Посмотреть через вэб интрефейс не получается, нет доступа.

  5. В общем то ситуация прояснилась. Заработал вэб интерфейс. Было из за неполной конфигурации после зависания установки.
    Вылечилось удалением /var/cache/debconf/config.dat & /var/cache/debcinfig/passwords.dat. После этого переконфигурировал natams и netams-web. Все работает.

  6. Пытаюсь поставить вручную, выходит следующее

    root@bta:~# dpkg –configure -a
    Processing triggers for man-db …
    dpkg: dependency problems prevent configuration of netams:
    netams depends on libnetfilter-queue1 (>= 0.0.13); however:
    Package libnetfilter-queue1 is not installed.
    netams depends on dbconfig-common; however:
    Package dbconfig-common is not installed.
    dpkg: error processing netams (–configure):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:
    netams

  7. 😉 сорри под конец рабочего дня с ума сходил уже разобался.

  8. Что
    Password input error!
    Please enter non-empty password.

    Бага с этой сборкой всё ещё актуальна… шо делать то будем?

Leave a Reply

Your email address will not be published. Required fields are marked *